問45応用情報技術者 平成29年度 春期
45 / 80問
平成29年度 春期2017年
VPNで使用されるセキュアなプロトコルであるIPsec,L2TP,TLSの,OSI基本参照モデルにおける相対的な位置関係はどれか。

選択肢をえらぶと、答えと解説が出ます
選択肢をえらぶと、
ここに答えと解説が出ます
ここに答えと解説が出ます

正答 3解説
正解は3。図のC(上からTLS、IPsec、L2TP)が正しい並び。L2TPはその名のとおりレイヤ2(データリンク層)のフレームをトンネルで運ぶプロトコル。IPsecはIPパケットそのものを暗号化・認証するネットワーク層のプロトコル。TLSはTCPの上で動き、アプリケーションの通信を保護するので、トランスポート層とアプリケーション層の間に位置する。下からL2TP、IPsec、TLSとなる。
- 1のAは、TLSを最下位、IPsecを最上位に置いていて逆。
- 2のBは、TLSをL2TPとIPsecの間に置いていて、IPsecとTLSの上下が逆。
- 4のDは、IPsecを最下位に置いていて、L2TPとIPsecの上下が逆。
根拠:RFC 2661(L2TP)、RFC 4301(IPsecのアーキテクチャ)、RFC 5246(TLS 1.2)。
KEY POINT
VPNのプロトコルは下からL2TP(第2層)、IPsec(第3層)、TLS(トランスポート層の上)の順。「技術要素」の他の問題
- 平成29年度 春期 問44攻撃にHTTP over TLS(HTTPS)が使われた場合に起こり得ることはどれか。
- 平成29年度 春期 問43図のような構成と通信サービスのシステムにおいて,Webアプリケーションの脆弱性対策のためのWAFの設置場所として,最も適切な箇所はどこか。ここで,WAFに…
- 平成29年度 春期 問42無線LAN環境におけるWPA2-PSKの機能はどれか。
- 平成29年度 春期 問41DNSキャッシュサーバに対して外部から行われるキャッシュポイズニング攻撃への対策のうち,適切なものはどれか。
- 平成29年度 春期 問40水飲み場型攻撃(Watering Hole Attack)の手口はどれか。
- 平成29年度 春期 問39経済産業省とIPAが策定した"サイバーセキュリティ経営ガイドライン(Ver1.1)"の説明はどれか。
出典:平成29年度 春期 応用情報技術者試験 午前 問45(独立行政法人 情報処理推進機構(IPA))
独立行政法人情報処理推進機構(IPA)が公表している過去問題です。IPA の「過去問題の使用について」に基づき、IPA が指定する形で出典を明記して掲載しています(利用の許諾申請は不要)。問題文・選択肢の内容は変えていません。元の問題冊子から文字を起こす都合で、改行・字間の空白は省き、英数字の全角・半角は元とそろえていない箇所があります。図表は IPA が公表した問題冊子のものです。解説は当サイトが独自に作成したもので、IPA とは関係ありません。
独立行政法人情報処理推進機構(IPA)が公表している過去問題です。IPA の「過去問題の使用について」に基づき、IPA が指定する形で出典を明記して掲載しています(利用の許諾申請は不要)。問題文・選択肢の内容は変えていません。元の問題冊子から文字を起こす都合で、改行・字間の空白は省き、英数字の全角・半角は元とそろえていない箇所があります。図表は IPA が公表した問題冊子のものです。解説は当サイトが独自に作成したもので、IPA とは関係ありません。
